Error message
Invalid Expense VAT code specified.Affected ERP integrations
Exact Online
Cause
This error occurs when the VAT code selected for an expense in Payhawk is not considered valid by Exact Online. This can happen for several reasons:
The selected VAT code exists in Exact Online but has been marked as Blocked, preventing its use in transactions.
The VAT code that was available when custom fields were synced to Payhawk has since been deleted from Exact Online.
The VAT code can have other configuration issues in Exact Online that prevent its use.
Solution
To resolve this issue:
Re-sync VAT codes from Exact Online:
In the Payhawk Web Portal, go to Settings > Integrations > Exact Online.
Click on its three-dot menu and select Manually sync to trigger a re-sync of the VAT codes from Exact Online.
Verify the VAT code in Exact Online, if the error persists:
Log in to your Exact Online account.
Navigate to Master Data > Tax > VAT Codes.
Locate the VAT code that Payhawk is attempting to use.
Ensure that the VAT code is not marked as Blocked and that all its settings are correctly configured.
If the VAT code is missing or blocked, you need to either unblock it, recreate it, or select an alternative, active VAT code.
Update the expense in Payhawk:
In the Payhawk Web Portal, go to Expenses and open the expense in Payhawk that failed to export by clicking on it.
Select a valid, unblocked VAT code from the refreshed list.
Save the expense and attempt to export it again.