The connection to NetSuite has been invalidated, please try connecting again.

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Error message

The connection to NetSuite has been invalidated, please try connecting again.

Affected ERP integrations

  • Oracle NetSuite

Cause

This error occurs when Payhawk receives an INVALID_LOGIN_ATTEMPT error from Oracle NetSuite. The error indicates that the connection has been broken, typically due to changes made in the ERP.

Common reasons include:

  • An Oracle NetSuite Administrator changed permissions on an ERP bundle script (not applicable for SuiteApp connections).

  • An Oracle NetSuite Administrator manually revoked the authentication token from the ERP.

The tokens used by Payhawk do not have an expiration date. Under normal circumstances, connection issues should not occur unless changes are made in Oracle NetSuite.

Solution

To resolve this issue:

  1. In Payhawk, navigate to Settings > Integrations > NetSuite.

  2. Disconnect and reconnect the NetSuite integration.

  3. Follow the authentication prompts to reestablish the connection.

  4. Verify that the connection is active and retry your export.