The user in your Exact Online account is blocked. Verify user access before trying an expense export.

Prev Next

Error message

The user in your Exact Online account is blocked. Please verify user access before trying an expense export.

Affected ERP integrations

  • Exact Online

Cause

This error occurs when the user account that was originally used to establish the connection between Payhawk and Exact Online has subsequently had their access revoked or blocked in Exact Online. Although the existing access token may not yet be expired, any requests Payhawk makes to Exact Online using that token will receive a 403 Forbidden response, thus blocking all export operations. This connection cannot be automatically restored from Payhawk's end and requires manual action.

Solution

You can resolve this issue in one of the following ways:

  • Unblock the user in Exact Online.

    1. Log in to your Exact Online account.

    2. Navigate to Master Data > Users.

    3. Locate the user that was used to connect the Payhawk integration and click on the user to view their details.

    4. Navigate to the Blocked setting and ensure it is turned off to restore the user's access.

    5. Save any changes made.

    6. Return to Payhawk and attempt to export the expense again.

  • Reconnect the integration with a valid user.

    1. In the Payhawk Web Portal, navigate to Settings > Integrations > Exact Online. Click on its three-dot menu and select Disconnect.

    2. Reconnect the integration using a valid and active user from the authorised users in your Exact Online account.

    3. Attempt to export the expense again.

To prevent this issue in the future, ensure that the user account used to connect the Payhawk integration remains active and unblocked in Exact Online. If that user's access needs to be revoked, reconnect the Payhawk integration with another authorised user beforehand.