An invalid value was provided for the field. Please select another value or check default values for the employees / vendors in NetSuite in case this field is not synced to Payhawk.

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Error message

An invalid value was provided for ${field}. Please select another value or check default values for the employees / vendors in NetSuite in case this field is not synced to Payhawk.

Affected ERP integrations

  • Oracle NetSuite

Cause

This error occurs when creating or updating a vendor bill, vendor credit, or expense report in Oracle NetSuite. The value provided for a specific field is not valid, most commonly because the value is inactive in the ERP or conflicts with default values set on the employee or vendor record.

Solution

To resolve this issue, use any of the following approaches.

Check if the field is synced in Payhawk

  1. In Payhawk, open the expense showing the error.

  2. Check if the field mentioned in the error is visible and has a value selected.

  3. Log in to Oracle NetSuite and verify that the selected value is active (not inactive or deleted).

  4. If the value is inactive, either reactivate it in the ERP or select a different valid value in Payhawk.

  5. Save the expense and retry the export.

If you were connected to an Oracle NetSuite Sandbox environment when setting custom field values, you may need to reselect the values after switching to Production.

Check default values on employee or vendor records in Oracle NetSuite

  1. Log in to the ERP.

  2. Navigate to the employee or vendor record associated with the expense.

  3. Check if the field has a default value set that may be overriding the value from Payhawk - for example, Department or Team.

  4. Update or remove the default value in Oracle NetSuite if necessary.

  5. Return to Payhawk and retry the export.

Check hidden fields in Payhawk

  1. In Payhawk, review the expense history to see if the field was previously set but is now hidden.

  2. If the field is hidden, make it visible in the expense settings.

  3. Select a valid value or deselect the current value.

  4. Save the expense and retry the export.

Update or remove default ERP values

If the field is not visible in Payhawk but the error still occurs, the value is likely set as a default on the employee or vendor record in Oracle NetSuite. Check the ERP record and update or remove the default value.