Error message
The payment cannot be exported due to currency incompatibility. Please make sure that all expenses, related to this payment have their periods open in NetSuite to enable currency change.Affected ERP integrations
Oracle NetSuite
Cause
This error occurs when exporting a bulk payment that includes expenses in different currencies. To pay multiple expenses with a single payment in Oracle NetSuite, all related vendor bills must be in the same currency.
Payhawk attempts to update the currency of already-exported vendor bills to match, but this requires the accounting period in the ERP to be open for changes. The error occurs when the vendor bill is in a closed period that does not allow currency updates.
Solution
To resolve this issue, use either of the following approaches:
Open the period for accounts payable changes
Log in to Oracle NetSuite.
Navigate to Setup > Accounting > Manage Accounting Periods.
Locate the periods containing the vendor bills referenced in the payment.
Ensure the period is not fully closed and has accounts payable changes allowed.
Save the changes.
Return to Payhawk and retry the export.

Change the period to an open one
In Oracle NetSuite, locate the vendor bills included in the payment.
Change their posting period to one that is currently open and allows accounts payable changes.
Return to Payhawk and retry the export.