Payment date or service period are set before Xero Period Lock Date.

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Error message

Payment date and/or service period are set before Xero Period Lock Date.

Cause

This error occurs when the payment date and/or service period date of an expense in Payhawk falls before the Period Lock Date set in your Xero account. Xero’s period lock functionality prevents any new transactions or modifications from being recorded in locked accounting periods and ensures the integrity and finality of your financial records for those periods.

When Payhawk attempts to export an expense with dates that fall within a locked period, Xero rejects the transaction and returns this error.

Solution

To resolve this issue:

  1. Log into your Xero account.

  2. In the Accounting menu, select Advanced.

  3. Click on Financial settings.

  4. Under Lock Dates, delete the date in the Lock Date field.

  5. Click on Save.

Note that users with the adviser user role can remove lock dates temporarily to allow changes to transactions.