Failed to export into Exact Online. Payment condition (Purchase) is not configured.

Prev Next

Error message

Failed to export expense. Payment condition (Purchase) is not configured in Exact Online.

Affected ERP integrations

  • Exact Online

Cause

While a Payment Condition is generally not a mandatory field for Purchase Entries in Exact Online, with exceptions for Germany and Spain, Payhawk attempts to create a default payment condition with the code PH (Payhawk Payment Condition) and use it for all entries.

This error typically occurs if:

  • The automatically created PH payment condition in Exact Online has been removed.

  • There is no default payment condition set in your Exact Online company settings.

Without an existing payment condition, either Payhawk's default or another one set as default, Exact Online cannot process the purchase entry, which leads to the export failure.

Solution

To resolve this issue:

  1. Log in to your Exact Online account.

  2. Go to Company name > Settings.

  3. Navigate to the General section of the settings page.

  4. Locate the Default payment condition (purchase) field.

  5. Select an appropriate payment condition from the drop-down menu to set it as the default. If the PH (Payhawk Payment Condition) exists, you can select it. Otherwise, choose another suitable payment condition.

    Company settings page showing payment conditions and account links for financial management.

  6. Click Save.

  7. Return to Payhawk and attempt to export the expense again. The export must now be successful.