Error message
Please select a customer for each billable split line.Affected ERP integrations
QuickBooks Online
Cause
This error occurs when an expense line item has been marked as Billable in Payhawk, but the corresponding Customers or Projects custom fields have not been populated.
When an expense is designated as billable, QuickBooks Online requires that it be associated with a specific customer, and optionally a project, so that it can be correctly invoiced back to them. If this information is missing, the export will fail.
Solution
You can resolve this issue in one of the following ways:
If the expense was marked as billable by mistake and will not be invoiced to a customer, change the Billable custom field to No:
Find the expense in Payhawk.
Locate the Billable custom field.
Change the value from Yes to No. The expense can now be exported successfully.
If the expense is correctly marked as billable, you must specify which customer and project it belongs to.
Find the expense in Payhawk.
Locate the Customers and Projects custom fields.
Select the appropriate customer and, if applicable, the project from the drop-down menus. Once these fields are populated, attempt the export again; it must now be successful.