Error message
Failed to export into QuickBooks Online. The selected account for a billable expense has an invalid type in QuickBooks Online. Please update the account type in QuickBooks Online or change the category mapping in Payhawk.Affected ERP integrations
QuickBooks Online
Cause
This error occurs when you are trying to export a billable expense to QuickBooks Online as a vendor bill, but the General Ledger (G/L) account mapped to the expense category in Payhawk has an account type that QuickBooks Online does not accept for billable expenses.
QuickBooks Online has specific restrictions on which account types can be used for billable expense transactions. If the mapped account type does not meet these requirements, the export will fail.
Valid account types for billable expenses
The following account types are valid for billable expenses in QuickBooks Online:
Expense
Other Expense
Cost of Goods Sold (COGS)
Other Current Liabilities
Other Current Assets
Other Assets
Fixed Assets
Solution
You can resolve this issue in one of the following ways:
Change the account type in QuickBooks Online.
Log in to your QuickBooks Online account.
Navigate to Settings and select Chart of Accounts.
Locate the G/L account that is mapped to your Payhawk expense category.
Click Edit next to the account.
Change the Account Type to one of the valid types listed above, for example, Expense, Other Expense, COGS, or else.
Click Save and Close.
Return to Payhawk and attempt to export the expense again.
Remap the expense category in Payhawk.
In the Payhawk Web Portal, navigate to your expense category mapping settings for QuickBooks Online.
Locate the expense category causing the error.
Remap it to a different G/L account in QuickBooks Online that already has a valid account type for billable expenses.
Save the updated mapping.