Failed to export due to temporary communication issues in Oracle NetSuite/Exact Online/Xero. Please try again later.

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Error message

Failed to export due to temporary communication issues in Oracle NetSuite/Exact Online/Xero. Please try again later.

Affected ERP integrations

  • Oracle NetSuite

  • Exact Online

  • Xero

Cause

This error occurs when the ERP system, such as Oracle NetSuite, Xero, or Exact Online, has rate limits on the number of API calls that can be made within a specific time period. When Payhawk reaches this limit for your account, the export is temporarily paused and automatically rescheduled.

Payhawk will retry the export multiple times over the next 24 hours. If the issue persists and the system is still unable to complete the export after this period, the export will fail with this error message.

This issue happens in the following cases:

  • A large number of expenses are exported simultaneously instead of being spread out throughout the day.

  • Your company has a high volume of transactions that may exceed the limits of your current plan or the ERP system's capacity.

Solution

To resolve this issue:

  • In Payhawk, re-review the expense, which failed to export, in order to initiate a new export attempt. Note that while this typically resolves the issue, there is no guarantee the export will succeed if the rate limit is still being exceeded.

  • Schedule exports throughout the day to avoid hitting API rate limits, instead of exporting large batches of expenses at once.

  • Contact your ERP provider to understand the API rate limits for your account and explore options to increase them, if necessary.