Failed to export into MS Business Central. The Payment journal cannot be found in MS Business Central.

Prev Next
This content is currently unavailable in Dutch. You are viewing the default (English) version.

Error message

Failed to export into MS Business Central. The Payment journal cannot be found in MS Business Central.

Affected ERP integrations

  • MS Business Central

Cause

This error occurs when the Payment journal that was previously configured in Payhawk has been removed or renamed in MS Business Central. The Payhawk system is unaware of this change because the configuration has not been updated in the portal.

Solution

To resolve this issue:

  1. In the Payhawk Web Portal, go to Settings > Integrations.

  2. On the MS Business Central integration, click on the three dots menu and select Edit configuration.

  3. Navigate to the Map Accounts section.

  4. Find the Payment Journal field and select a new, valid journal from the drop-down list.

    Payments configuration section displaying Payments Journal and General options for settings.

  5. Click on Save changes.

  6. In the Payhawk Web Portal, return to the Expenses app and try to export the expense again.