Error message
Payment cannot be exported due to a changed supplier.Affected ERP integrations
Oracle NetSuite
Cause
This error occurs when the expense was exported with one supplier, then the supplier was changed and the expense was paid. When Payhawk attempts to export the payment, it tries to update the supplier on the vendor bill in Oracle NetSuite, but this fails because the bill is in a closed accounting period. This creates a mismatch between the supplier on the vendor bill and the supplier on the payment.
Solution
To resolve this issue:
Manually update the supplier on the vendor bill in Oracle NetSuite to match the current supplier.
Retry the payment export from Payhawk.