Error message
Invalid supplier currency. Please change the supplier or create a new one with currency X.Affected ERP integrations
QuickBooks Online
Cause
This error occurs because in QuickBooks Online, each vendor (supplier) has a defined currency, and only vendor bills in that specific currency can be linked to that vendor. If you attempt to create a vendor bill in a different currency than the one assigned to the supplier, QuickBooks Online will reject the transaction.
For example, if you have a supplier set up with EUR as their currency, but you're trying to record a GBP expense with that same supplier, the export will fail because the currencies don't match.
Solution
You can resolve this issue in one of the following ways:
Change the supplier selected on the expense - Select a different supplier in Payhawk that has the correct currency assigned to them in QuickBooks Online.
Create a new supplier with the required currency - If you have expenses with different currencies for the same supplier, you'll need to create multiple versions of that supplier in QuickBooks Online, one for each currency:
In QuickBooks Online, create a new supplier with the same name, adding the currency code to differentiate them, for example, Supplier Name EUR and Supplier Name GBP.
Assign the appropriate currency to each supplier version when creating them.
Once created, these suppliers will sync to Payhawk automatically.
In your Payhawk expense, select the supplier version with the matching currency. The export must now be successful.
If a currency isn't available in the Payhawk supplier dropdown, add it to your QuickBooks Online account first. For more information, see the list of supported currencies in QuickBooks Online.
Payhawk syncs currencies nightly from QuickBooks Online, so new currencies will appear in your entity within 24 hours.