Invalid service period date

Prev Next
This content is currently unavailable in French. You are viewing the default (English) version.

Error message

Invalid service period date.

Affected ERP integrations

  • DATEV

  • Exact Online

  • MS Business Central

  • Microsoft Dynamics 365 Finance & Operations

  • Oracle NetSuite

  • QuickBooks Online

Cause

This error indicates that the service or accounting period corresponding to the expense’s date has been closed in your integrated accounting system. Exports cannot be posted to a closed period.

Solution

You can resolve the issue in one of the following ways:

  • Reopen the closed accounting period in your external ERP integration.

    1. Log in to your accounting system, for example, DATEV, Exact Online, MS Business Central, Microsoft Dynamics 365 Finance & Operations, Oracle NetSuite, or QuickBooks Online.

    2. Navigate to your accounting periods and reopen the specific period that the expense needs to be posted to.

    3. Once the period is open, return to the Payhawk portal and re-export the expense. No changes are needed on the expense itself.

  • Change the expense date in Payhawk.

    1. In the Payhawk Web Portal, go to the Expenses app.

    2. Click on the expense that failed to export to open its details view. You can apply the Failed export filter to locate the expense quickly.

    3. Check the date and adjust it to the first available date of the next open accounting period.

    4. Click on Save and try to export the expense again.