Failed to export into MS Business Central. An upgrade for Purchase Credit Memo API is required in MS Business Central.

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Error message

Failed to export into MS Business Central. An upgrade for Purchase Credit Memo API is required in MS Business Central. Please contact your MS Business Central administrator.

Affected ERP integrations

  • MS Business Central

Cause

This error indicates that the version of the Purchase Credit Memo API in your MS Business Central environment is outdated and requires an upgrade to process the data being exported from Payhawk.

Solution

To resolve this issue:

  1. Log in to your MS Business Central account.

  2. Use the search function to find and open API Data Upgrade List.

  3. In the list, select the line item for PURCHASE CREDIT MEMOS and then click the Schedule Upgrades action in the toolbar.

    A screenshot of an API Data Upgrade List with "PURCHASE CREDIT MEMOS" highlighted as "Scheduled" and "SALES CREDIT MEMOS" as "Completed".

  4. Follow the prompts in the subsequent windows to schedule and complete the upgrade.

  5. Once the upgrade is complete, return to the Payhawk Web Portal and try to export the credit memo again.