Failed to export into Xero. Unable to create X currency.

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Error message

Failed to export into Xero. Unable to create X currency.

Cause

This error occurs when Payhawk attempts to export an expense to Xero using a currency that is not enabled in your Xero account. When creating an invoice or bill, Xero requires that the currency be pre-configured and active within your account’s settings. If the currency from the expense in Payhawk has not been added to Xero, the export will fail with the above error message.

Solution

To resolve this issue:

  1. Add the currency in Xero.

    1. Log in to your Xero account.

    2. Follow the instructions on adding a foreign currency in Xero.

    3. Ensure the currency is activated and available for use.

  2. Re-review the expense in Payhawk.

    1. Go to your Payhawk account.

    2. Locate the expense that failed to export.

    3. Re-review the expense to initiate a new export attempt.

  3. Proceed with processing the bank payment as usual, once the export is successful and the invoice or bill is created in Xero with the correct currency.